[SOLVED] No response. Is aria2 shutdown?

Are you having a problem with a Development release of uGet? If so, please let us know here. - Note*: Development releases are unstable beta releases and are available for those who like to use bleeding edge software but we recommend that you use the latest Stable release.

[SOLVED] No response. Is aria2 shutdown?

Postby esgwpl » Sat Oct 18, 2014 10:37 pm

I'm having trouble getting uGet to use Aria2 as its backend, basically I can't start any download when setting Aria2 as the backend, it always results in "Message: No response. Is aria2 shutdown?"

OS: Xubuntu 14.04 32 bit
uGet: 1.99.3
Aria2: 1.18.1

Here's how the setting looks like:

Image

Some things I noticed, uGet does start Aria2 when started, I know that it is running by looking at a process list:

Image

Weird thing is the Aria2 process doesn't shut down with uGet when uGet is closed, uGet also won't start until I kill the Aria2 process using the task manager.

I tried going back to the stable version (1.10.4) and Aria2 works fine there, I just don't want to go back because I've had an issue with download queue being stuck when a download is finished on the stable version.
esgwpl
 
Posts: 2
Joined: Sat Oct 18, 2014 10:26 pm
Linux Distro: Xubuntu

Re: No response. Is aria2 shutdown?

Postby MichaelTunnell » Sun Oct 19, 2014 9:18 pm

Try this in aria2 settings...

URL:
http://localhost:6800/jsonrpc

Arguments:
--enable-rpc=true -D --disable-ipv6 --check-certificate=false
User avatar
MichaelTunnell
Site Admin
 
Posts: 510
Joined: Sun Sep 02, 2012 1:01 pm
Location: Alabama, USA
uGet Version: Latest Dev Build
Operating System: Linux
System Architecture: 64bit
Linux Distro: Kubuntu & Antergos

Re: No response. Is aria2 shutdown?

Postby esgwpl » Mon Oct 20, 2014 1:24 am

That seems to fix it, thanks.
esgwpl
 
Posts: 2
Joined: Sat Oct 18, 2014 10:26 pm
Linux Distro: Xubuntu

Re: No response. Is aria2 shutdown?

Postby MichaelTunnell » Mon Oct 20, 2014 10:01 am

You're welcome
User avatar
MichaelTunnell
Site Admin
 
Posts: 510
Joined: Sun Sep 02, 2012 1:01 pm
Location: Alabama, USA
uGet Version: Latest Dev Build
Operating System: Linux
System Architecture: 64bit
Linux Distro: Kubuntu & Antergos

Re: [SOLVED] No response. Is aria2 shutdown?

Postby jack007sparrow » Fri Nov 03, 2017 10:09 pm

I use Linux Mint 18.2 and have Uget 2.0.10 installed, my config settings are as specified and yet I get the error: "Message: No response. Is aria2 shutdown?". Any help would be appreciated.
Image
jack007sparrow
 
Posts: 1
Joined: Fri Nov 03, 2017 8:42 pm
uGet Version: 2.0.10
Operating System: Linux
System Architecture: 64bit
Linux Distro: Mint 18.2


Return to Development Release Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron